gitprompt, Bash 4.4, and $PS0

I spend a lot of time on a computer, and I have thoroughly customed my environment to be just the way I like it. It's over here on Github, and I use it everywhere.

In late 2015, bash 4.4 or so picked up the ability to display a PS1-style prompt immediately before a command starts. They called the environment variable that houses this prompt definition PS0. This broke gitprompt something fierce.

Today, I installed A 4.4.x bash on one of my FreeBSD boxen, and got bit.

I patched gitprompt on my local env, but since I don't know where it canonically lives, I couldn't patch it "upstream" — c'est la vie!

tl;dr If you want to upgrade to Bash 4.4.x, and you use gitprompt, you really want to apply this patch, and if you are setting $PS0 for a custom gitprompt, change that over to PSGIT.

James (@iamjameshunt) works on the Internet, spends his weekends developing new and interesting bits of software and his nights trying to make sense of research papers.

Currently working on Rook.